Thread: Upcoming updates to irisFetch.m and IRIS-WS Java library

Started: 2020-05-06 12:56:39
Last activity: 2020-05-19 11:42:56
Topics: Web Services
Attention all irisFetch.m Matlab users:

In order to accommodate recent updates to our various web services, we will soon be upgrading both the main irisFetch.m m-file and the tool's underlying IRIS-WS Java library. One of the primary consequences of this update is that the IRIS-WS Java library will no longer support version 7 of Java (JDK 1.7).

**PLEASE NOTE**
This will directly impact all users who are running versions of Matlab prior to version 2017b. We highly recommend updating your Matlab to version 2017b, or a more recent version, at your earliest convenience.
**

As outlined in this document provided by Mathworks, the JDK used by Matlab was upgraded to JDK 1.8 starting with the 2017b release (https://www.mathworks.com/content/dam/mathworks/mathworks-dot-com/support/sysreq/files/SystemRequirements-Release2017b_SupportedCompilers.pdf) Going forward, we will be requiring this version as a minimum system requirement for running the IRIS-WS Java library.

We expect that the updates to irisFetch.m and the IRIS-WS Java library will be released within the next two weeks, so please consider using this time to update your version of Matlab to ensure a smooth transition and avoid any disruptions to your workflows. A final decision on the exact release dates will be announced to this listserve soon.

If you have any questions or concerns about usage of irisFetch.m or the IRIS-WS Java library, please direct your inquiries to ws-issues<at>iris.washington.edu <ws-issues<at>iris.washington.edu> and we will do our best to address your concerns.

Thank you,
IRIS Web Services
  • Hello Web Service users,

    As a follow-up to the previous email, we will be releasing the updates to the IRIS-WS library and the irisFetch.m Matlab client tomorrow (Wed May 20) afternoon. Please consider upgrading your version of Matlab at your earliest convenience to avoid any disruptions to your workflows.

    Thank you,
    IRIS Web Services

    On May 6, 2020, at 12:56 PM, Robert Weekly <rtweekly<at>iris.washington.edu> wrote:

    Attention all irisFetch.m Matlab users:

    In order to accommodate recent updates to our various web services, we will soon be upgrading both the main irisFetch.m m-file and the tool's underlying IRIS-WS Java library. One of the primary consequences of this update is that the IRIS-WS Java library will no longer support version 7 of Java (JDK 1.7).

    **PLEASE NOTE**
    This will directly impact all users who are running versions of Matlab prior to version 2017b. We highly recommend updating your Matlab to version 2017b, or a more recent version, at your earliest convenience.
    **

    As outlined in this document provided by Mathworks, the JDK used by Matlab was upgraded to JDK 1.8 starting with the 2017b release (https://www.mathworks.com/content/dam/mathworks/mathworks-dot-com/support/sysreq/files/SystemRequirements-Release2017b_SupportedCompilers.pdf) Going forward, we will be requiring this version as a minimum system requirement for running the IRIS-WS Java library.

    We expect that the updates to irisFetch.m and the IRIS-WS Java library will be released within the next two weeks, so please consider using this time to update your version of Matlab to ensure a smooth transition and avoid any disruptions to your workflows. A final decision on the exact release dates will be announced to this listserve soon.

    If you have any questions or concerns about usage of irisFetch.m or the IRIS-WS Java library, please direct your inquiries to ws-issues<at>iris.washington.edu <ws-issues<at>iris.washington.edu> and we will do our best to address your concerns.

    Thank you,
    IRIS Web Services


Page built 23:19:42 | v.090361a2