Thread: Installation of SAC 101.5; operating system issues

Started: 2011-11-23 23:26:11
Last activity: 2011-11-24 16:56:47
Topics: SAC Help
Fiona Darbyshire
2011-11-23 23:26:11

Today I obtained and installed SAC 101.5 for a Linux 64-bit system.
(I've successfully installed previous versions on this machine). When
I tried to run the program, I received the following error message:

sac: /lib64/ version `GLIBC_2.7' not found (required by sac)
sac: /lib64/ version `GLIBC_2.11' not found (required by sac)

Not being any expert on OS libraries, I asked the system administrator
for advice. He told me that my machine has operating system CentOS 5.7
which has the version GLIBC 2.5 and one cannot install a more recent
version by the distribution update system (apologies if this is clumsy
wording; I'm translating directly from French...). CentOS 6 uses GLIBC
2.12 but my machine is 5 years old...

So my question is: is there a way to do a successful install of the
sac 101.5 binaries without having to upgrade my entire operating
system? I'd imagine there's a simple solution out there somewhere, but
I'm not sufficiently computer-savvy to figure it out myself! The
adminstrator wondered if there's a version with all libraries included
that was therefore independent of the OS libraries.

Thanks in advance for your advice!

Fiona Darbyshire
Université du Québec à Montréal

  • Sheila Peacock
    2011-11-24 16:56:47
    Dear Fiona,

    I got the same message from the 64-bit version of the pre-compiled SAC.
    The 32-bit version worked OK on an older 32-bit computer. Sorry I
    don't know how to get round the GLIBC version problem. I have
    had to compile up a working version of SAC 101.5 from the source code anyway
    (because I had to modify one of the subroutines to satisfy local
    needs here). As these things go it was straightforward. If your
    system has the Gnu C compiler (type "which gcc" to see if it has)
    then perhaps you can compile the source code with the default
    settings, i.e. unpack the tar file of source code, type "configure" then "make"
    then "make install" (you might need to be "root" to run "make install").
    You will have to ask for the source code distribution from IRIS if you
    didn't get it along with the precompiled binaries.

    Actually I have simplified this too much. This was the command I
    issued to invoke the "configure" script:

    configure --prefix=/sharedprograms/sac/v101.5/64c

    The "--prefix=/sharedprograms....."
    directed "make install" to install the completed SAC program into
    /sharedprograms/sac/v101.5/64c which does not need me to be "root" for access.
    My CentOS system seemed otherwise to have everything SAC needed
    (in particular, "libpng.a", in the default places, fortunately.

    Sheila Peacock.

06:52:58 v.f0c1234e