SAC Help

A forum for SAC users to exchange ideas and ask questions about SAC usage, installation, portability, etc.

Email address
sac-help@lists.ds.iris.edu
Type
Moderated by
IRIS Webmaster
Related tags
SAC Software SAC
Login to manage your subscriptions

Active Message Threads for September 2015

Sheila Peacock
2015-09-28 17:02:42 - 2015-09-28 21:43:07
I want to test the basic algorithms of another program that reads only CSS-format data from arrays. Hence I generated a set of impulses in SAC and tried to write them to a CSS-format file with "writecss". This failed with ERROR 1385: No worksets in memory. The traces look OK with "p1", which I assume means that they are "in memory". I tried to write the same set of impulses into an IMS (GSE) file with "writegse" (because I could convert this format to CSS with another program) but this c... [more]
Replies
Shahar Barak
2015-09-21 16:56:39 - 2015-09-22 20:35:59
Hi, I couldn't find in the Users Manual how to parse SAC ASCII files (write alpha). I see 30 header lines and 3 tail lines. In between I see 5 columns. Can anyone help me or point me to the right page in the manual? Thanks, Shahar
Replies
Shahar Barak
2015-09-15 16:18:39 - 2015-09-16 16:04:58
Hi, I would like to read multiple SAC files into memory using a file which contains the SAC file names. According to the SAC book, I can do: systemcommand to list cat list_file while read list filename read filename enddo However, I get the error: "sh: to: command not found" Why isn't this working? According to the online command index there's no "to" syntax for systemcommand: http://ds.iris.edu/files/sac-manual/commands/systemcommand.html Is there a different way to do this? Thanks, ... [more]
Replies
Milton Plasencia
2015-09-11 11:51:26 - 2015-09-11 19:01:47
Silvana, Checking old e-mails of the sac-help, i find an e-mail from Brian Savage (Set,15 2009) where him suggest the update of sac software to avoid the X problem. Cheers, Milton > On Sep 10, 2015, at 23:49, Silvana Spagnotto <pampa113@gmail.com> wrote: > > I tried it both ways, even on very short windows, of 5 seconds. I tried too with "decimate" to lower points and the same, the error is > > Window size: 200 Overlap: 180 FFT size: 512 > Warning: ORDER begin reset to 1/2 length ... [more]
Replies
Milton Plasencia
2015-09-11 11:27:51
Hola Silvana, The problem seems your video card, the error : X Error of failed request: BadMatch (invalid parameter attributes) googling it to see a possible solution. Can you plot the trace only? to check that X system works. i assume you running on sac on Linux. Is true i use OS X 64 bits and sac 101.6a (last version). HTH, Milton
No replies
Silvana Spagnotto
2015-09-10 19:25:39 - 2015-09-11 02:22:32
Hello: I need plot a spectrogram, but this script only work in SAC 64 bits sac > r 2005.*SAC SAC> rmean SAC> rtr SAC> taper SAC> interpolate delta 0.2 SAC> spectrogram window 200 slice 50 method mem order 400 ymin 0.0 ymax 0.1 cbar off noscaling in 32 bits the error is Window size: 999 Overlap: 749 FFT size: 2048 Spectrogram dimensions are 512 by 3 . X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 72 (X_PutImage) Serial number of ... [more]
Replies
ali92ah@yahoo.co.uk
2015-09-10 13:49:58 - 2015-09-10 23:05:32
Hello, I am trying to install SAC v101.6a software package 64 bit. I was able to unzip the package, but kinda stuck after this step! it seem to be a stupid asking the following, but I am kinda need/want to have sac. I would appreciate if someone would kindly help me setting up SAC correctly? I don’t think I know how to set up SACAUX? Thank you very much & sorry to post this Ali
Replies
Ali Shaikhsulaiman
2015-07-26 07:18:25 - 2015-09-10 23:03:41
Hey! I am having a problem installing SAC on my mac (OS X Yosemite 10.10). I have tried to run the script (./sacinit.sh) on bash, don’t observe any action… and then tried to check if sac has been installed somehow, however a message shows up "bash: /usr/local/bin/sac: Bad CPU type in executable”.. I am right thinking it is because of the version of my OS? since sac is only possibly valid for upto OS10.9? *would really like away to be able to install sac with on my mac? Appreciate any he... [more]
Replies
Sarah A
2015-09-08 19:41:44 - 2015-09-09 07:42:42
Hello, I’m trying to run SAC on a Macbook pro running OS X 10.10.4. I successfully unpacked the tar.gz file into my Documents folder and pasted the appropriate lines in my bashrc file; however, SAC isn’t running. When I try to navigate to the SAC program in xterm, it prints the following error: ERROR 108: Number 108 /Users/smarveson/Soft/sac/aux/messages /Users/smarveson/Soft/sac/aux/csspickpref . readcss will not read picks. ERROR: Number 901 in INITCOMLISTS. Problems opening C... [more]
Replies
Rajesh Mahanty
2015-09-01 05:43:55
hell sir, i am arjun singha roy stand at an age of 74yrs from village name chaitanyapur of west Bengal belong to country. i have already forecast several of major and the minor earth quakes which had been occurring in the coastal region of NEPAL and India. where as from my opinion a minor earthquake of range will takes places in NEPAL within 6 days from day effected from today(01/09/2015). sir please take my opinion seriously as possible, i have already pre forecast about the major earth qua... [more]
No replies
Page built 06:47:40 | v.6a0a3e16