Thread: Re: sac-help Digest, Vol 15, Issue 7

Started: 2006-09-15 00:04:04
Last activity: 2006-09-15 00:04:04
Topics: SAC Help
Jim Lawson
2006-09-15 00:04:04
My experience with many versions of SAC on SUNOS, Solaris
and SuSe Linux is that neither SAC macros, nor SAC data
files require an extention. I use macro names with no extention
and .sac for data, but the .sac is only needed because I
have written file manipulation and auto ftp programs
(in expect, bash, perl) to expect it.

Jim Lawson
Oklahoma Geological Survey Observatory
Leonard OK

but, i'm wondering what should the Macro file extension should be
after creating them with text editors..? and do i need do add
SETMACRO command in the sart up system file like .cshrc..?

by the way, i'm running SAC2000 Version 00.58d. on SUN os 5.8.

sorry, i could find any answer to my problem in the mailing list
archieve otherwise i won't send it.

any help? any idea?

i appreciate it,

thank you

Stanton, Megan M2Sr at
Fri Jun 16 11:46:53 PDT 2006
Previous message: [SAC-HELP] MACRO
Next message: [SAC-HELP] Filtering
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]


Oops my apologies. Setmacro didn't work for me on a very old
version, 0.56a. I hadn't used it on v100. It works fine in v100.
Leah what version are you using? -----Original Message-----
From: sac-help-bounces at [mailto:sac-help-
bounces at] On Behalf Of Brian Savage Sent:
Friday, June 16, 2006 11:33 AM To: sac-help at
Subject: Re: [SAC-HELP] MACRO Megan The setmacro command
works fine for me. The macro command looks first in the current
directory, then the directories defined by setmacro, and finally
in the macros directory like /usr/local/sac/aux/macros. Could
you provide the version of sac you are using and the command
sequence you tried, so we can track down this problem. Cheers,
Brian Stanton, Megan wrote: > I also found the setmacro
command did not work. However I do know > where SAC looks for the
macros so I just put them in there myself. The > only difference in
this directory location for you would be the first > two
directories in my location. So mine looks like this >
/home/sacv100/sac/aux/macros. Put the macros in the macros
directory > and make sure they are executable. Also just typing m
is shorthand for > macro. Saves a few key strokes. > > HTH,
Megan > > -----Original Message----- > From: sac-help-bounces
at > [mailto:sac-help-bounces at] On Behalf Of > feigelso at >
Sent: Thursday, June 15, 2006 3:16 PM > To: sac-help at > Subject: [SAC-HELP] MACRO > > Sac-help,
I made a small MACRO file using TextEdit. I put this into my
directory that has saved my practice problems when using SAC
(/usr/local/bin). I saved this small MACRO file as practice. In
SAC I typed: > > SAC>MACRO practice > > It then says that
the MACRO file is not found. I tried the SETMACRO > command but
was given the same thing.
Does anyone know what I'm doing > wrong? > > Thanks for your
help, > > Leah > > >
_______________________________________________ > sac-help mailing
list > sac-help at > > > >
_______________________________________________ > sac-help mailing
list > sac-help at >
_______________________________________________ sac-help mailing
list sac-help at


Previous message: [SAC-HELP] MACRO
Next message: [SAC-HELP] Filtering
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

More information about the sac-help mailing list

Want to be your own boss? Learn how on Yahoo! Small Business.
-------------- next part --------------
An HTML attachment was scrubbed...


Message: 2
Date: Wed, 13 Sep 2006 08:25:04 -0400 (EDT)
From: Arthur Snoke <snoke<at>>
Subject: Re: [SAC-HELP] sacio.a for Intel Mac
To: Georgia Cua <georgia.cua<at>>
Cc: SAC-help Listserv <sac-help<at>>
Message-ID: <Pine.GSO.4.61.0609130812300.28690@equake>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed


IRIS has two SAC packages: compiled versions for different OS (mac,
solaris) and a version with source code and makefiles. The top
in the binaries-only is ./sac and there ;is no ./sac/src. The top
directory in the more complete package is ./SAC, and the Makefile
is in
.SAC/src. (This is all discussed in ./SAC/Readme.buildsac.) From
you say, you have the binaries-only distribution.

The error messages indicates that sacio.a is not being accessed.
As you
are on an intel mac and the pre-built binaries and sacio.a were
built on a
non-intel mac, even if you have sacio.a in your library path, it
will not work. (I do not have access to an intel mac, so do not
exactly how far rosetta goes in allowing one on Intel mac to use
built on non-intel mac.)

Kevin's report is good news -- that it is possible to build sac
sources on intel mac and get it to work. That is the first report
I have
heard along these lines.


On Wed, 13 Sep 2006, Georgia Cua wrote:

Thanks for your reply Kevin.

Are you using the version 100.1 beta?

I also have a macbook pro with intel processors. Thus far, I am
using sac
v100, and when I untarred the file, there was no /sac/src
directory. I
actually have a sacio.a file, but when I try linking to it, I get
like the following..

/usr/bin/ld: warning /Applications/sac/lib/sacio.a archive's
cputype (18,
architecture ppc) does not match cputype (7) for specified -arch
flag: i386
(can't load from it)
/usr/bin/ld: Undefined symbols:
collect2: ld returned 1 exit status

Perhaps I will try 100.1 beta.

Thanks again,


On Sep 12, 2006, at 6:15 PM, Kevin Mayeda wrote:

Hi Georgia...

I downloaded everything from IRIS. After untarring
the file, I went into /sac/src and found the
'makefile'. I just simply typed 'make SACIO and it
created the sacio.a file in the /sac/lib directory.

Voila! It worked!

good luck..., let me know if you have issues...,
perhaps I can help. Keep in mind that I have a
MacBook Pro w/Intel processors..., your environment
might be different.

- Kevin Mayeda


sac-help mailing list

End of sac-help Digest, Vol 15, Issue 7

17:34:01 v.eb79165e