Thread: about MACROs...!!

Started: 2006-09-14 17:16:16
Last activity: 2006-09-14 17:16:16
Topics: SAC Help
2006-09-14 17:16:16

i'm new Sac user. and i have read all the e-mails regarding the Macros. actaully i have faced the same problem as Leah found it.

i'm trying now practicing the macro using the SAC manual. but, the first problem i have found is the macro which i creat doesn't work? same as leah...!!
it says that the MACRO file is not found..!!

but, i'm wondering what should the Macro file extension should be after creating them with text editors..? and do i need do add SETMACRO command in the sart up system file like .cshrc..?

by the way, i'm running SAC2000 Version 00.58d. on SUN os 5.8.

sorry, i could find any answer to my problem in the mailing list archieve otherwise i won't send it.

any help? any idea?

i appreciate it,

thank you

Stanton, Megan M2Sr at
Fri Jun 16 11:46:53 PDT 2006
Previous message: [SAC-HELP] MACRO
Next message: [SAC-HELP] Filtering
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Oops my apologies. Setmacro didn't work for me on a very old version, 0.56a. I hadn't used it on v100. It works fine in v100. Leah what version are you using?

-----Original Message-----
From: sac-help-bounces at
[mailto:sac-help-bounces at]
On Behalf Of Brian Savage Sent: Friday, June 16, 2006 11:33 AM
To: sac-help at
Subject: Re: [SAC-HELP] MACRO

Megan The setmacro command works fine for me.
The macro command looks first in the current directory, then the directories defined by setmacro, and finally in the macros directory like /usr/local/sac/aux/macros. Could you provide the version of sac you are using and the command sequence you tried, so we can track down this problem.

Cheers, Brian

Stanton, Megan wrote:

I also found the setmacro command did not work. However I do know where SAC looks for the macros so I just put them in there myself. The only difference in this directory location for you would be the first two directories in my location. So mine looks like this /home/sacv100/sac/aux/macros. Put the macros in the macros directory and make sure they are executable. Also just typing m is shorthand for macro. Saves a few key strokes.

HTH, Megan

-----Original Message-----
From: sac-help-bounces at
[mailto:sac-help-bounces at]
On Behalf Of feigelso at
Sent: Thursday, June 15, 2006 3:16 PM
To: sac-help at

I made a small MACRO file using TextEdit. I put this into my directory that has saved my practice problems when using SAC (/usr/local/bin). I saved this small MACRO file as practice.
In SAC I typed: SAC>MACRO practice
It then says that the MACRO file is not found. I tried the SETMACRO command but was given the same thing. Does anyone know what I'm doing wrong? Thanks for your help,


sac-help mailing list > sac-help at
sac-help mailing list sac-help at
sac-help mailing list sac-help at

Want to be your own boss? Learn how on Yahoo! Small Business.
04:09:24 v.f0c1234e