Thread: Re: SAC on Mac OSX 10.12 Sierra

Started: 2016-10-26 00:31:51
Last activity: 2016-10-26 00:31:51
Topics: SAC Help
Larry Baker
2016-10-26 00:31:51
Steve,

I was just reading about changes to /usr now being blocked in Mac OS X for another completely different reason today. This may help you.

https://digitizor.com/fix-homebrew-permissions-osx-el-capitan/

I am running El Capitan as of last week. I have not yet tried to install SAC. I already had files in /usr/local, so I did not have to do what this web page says. All I had to do was sudo chown to my new UserID. I think I created those using the admin account our IT group created to install the cruft they put on all our PCs and Macs for Active Directory.

If I were you, I would first try to enable the root account (https://support.apple.com/en-us/HT204012) and sudo su -l. Try to make the changes using the root account. That should be simpler than booting into single user mode.

Larry Baker
US Geological Survey
650-329-5608
baker<at>usgs.gov



On 25 Oct 2016, at 5:21:59 PM, Joe Fletcher <jfletcher<at>usgs.gov> wrote:



Begin forwarded message:

From: Steven Taylor <srt-rmg<at>comcast.net <srt-rmg<at>comcast.net>>
Subject: [sac-help] SAC on Mac OSX 10.12 Sierra
Date: October 25, 2016 at 5:19:32 PM PDT
To: SAC Help <sac-help<at>lists.ds.iris.edu <sac-help<at>lists.ds.iris.edu>>

Has anybody tried getting SAC going on Mac OS X 10.12 Sierra?

I can’t get the X11R6 directory over to /usr which used to do the trick.

Apple has blocked the ability to make any changes to /usr

Thanks,

Steve Taylor

----------------------
SAC Help (http://ds.iris.edu/message-center/topic/sac-help/)

Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
Update subscription preferences at http://ds.iris.edu/account/profile/




03:14:11 v.f0c1234e