Thread: Are there simple fixes for saveimg and plotpm commands?

Started: 2016-11-08 22:23:50
Last activity: 2016-11-09 17:25:50
Topics: SAC Help
Sac’s ‘saveimg’ command produces some very nice looking plots.

It works very nicely with trace plots I create with the ‘plot1' sac command.

But, I recently tried it out with some particle motion plots generated by the ‘plotpm’ sac command. Although an x-windows 'plotpm’ plot is visible on my screen when I use the ‘saveimg’ command, the .pdf file plot shows only the first segment of the original plotpm plot (it seems to be the line segment between the first and second data points). And a .ps file generated by ‘saveimg' from a ‘plotpm' plot does not open with either Preview or ghostscript on my Mac.

Are there any simple fixes for these problems? (User error is always a possibility).

My second question is whether there also might be a simple way to get plotpm to annotate either the start/first point or end/last point of a hodogram plot trace?

I’ve found ways to work around both these problems, so neither are what I would consider very high priority.

Some details: sac version 101.6a, MacOS version 10.11.6 (‘El Capitan’).

Thanks for your help,
Leigh House


  • Dear All -

    The SYMBOL command with a large spacing value might allow you to put a symbol on the path at the start. First draw the path, then re-draw with symbols.

    On 9 Nov 2016, at 06:25, Leigh House <hagar<at>newmexico.com> wrote:

    ...

    My second question is whether there also might be a simple way to get plotpm to annotate either the start/first point or end/last point of a hodogram plot trace?

    ...

    Thanks for your help,
    Leigh House
    ...

    George Helffrich
    george<at>elsi.jp


  • Leigh,

    Can you send me the file and commands you use to make the plot ?

    I will look into this. It sounds familiar.

    Brian

    On Nov 8, 2016, at 4:25 PM, Leigh House wrote:

    Sac’s ‘saveimg’ command produces some very nice looking plots.

    It works very nicely with trace plots I create with the ‘plot1' sac command.

    But, I recently tried it out with some particle motion plots generated by the ‘plotpm’ sac command. Although an x-windows 'plotpm’ plot is visible on my screen when I use the ‘saveimg’ command, the .pdf file plot shows only the first segment of the original plotpm plot (it seems to be the line segment between the first and second data points). And a .ps file generated by ‘saveimg' from a ‘plotpm' plot does not open with either Preview or ghostscript on my Mac.

    Are there any simple fixes for these problems? (User error is always a possibility).

    My second question is whether there also might be a simple way to get plotpm to annotate either the start/first point or end/last point of a hodogram plot trace?

    I’ve found ways to work around both these problems, so neither are what I would consider very high priority.

    Some details: sac version 101.6a, MacOS version 10.11.6 (‘El Capitan’).

    Thanks for your help,
    Leigh House


    ----------------------
    SAC Help (http://ds.iris.edu/message-center/topic/sac-help/)

    Sent from the IRIS Message Center (http://ds.iris.edu/message-center/)
    Update subscription preferences at http://ds.iris.edu/account/profile/


Page built 09:10:21 | v.b'108166