Thread: FDSN 1.1 services at the IRIS DMC

Started: 2014-04-28 22:02:36
Last activity: 2014-04-29 20:34:31
Topics: Web Services
Chad Trabant
2014-04-28 22:02:36

Hello WS users,

Tomorrow we will be updating all of our fdnsws web services (dataselect, event and station) to version 1.1 of the specification: http://www.fdsn.org/webservices/

The vast majority of users will not notice the difference as the changes are very few (the DMC’s services have mostly been 1.1 compliant for a long time). The fdnsws-dataselect and fdsnws-event services will simply have their version number updated. The fdsnws-station service will get a version number update and the service will support a new POST capability as documented in the specification and will be described on the service help pages.

The version number of the services themselves (as reported at, e.g., http://service.iris.edu/fdsnws/station/1/version) is used by the IRIS-WS Java library, which is used by the DMC’s irisFetch.m MATLAB script, and perhaps other software. All versions of the IRIS-WS library prior to 2.0.4 will cease function properly due to the version change. To ensure uninterrupted data flow please confirm that you are using the latest (2.0.6) version of IRIS-WS, available here:

http://www.iris.edu/dms/nodes/dmc/software/downloads/IRIS-WS/

regards,
IRIS DMC



  • Chad Trabant
    2014-04-29 20:34:31

    Hello WS users,

    The IRIS DMC’s FDSN web services have all been updated to version 1.1.

    http://service.iris.edu/fdsnws/station/1/
    http://service.iris.edu/fdsnws/dataselect/1/
    http://service.iris.edu/fdsnws/event/1/

    As described below, the dataselect and event services have not changed in functionality, only their version numbers were updated.

    The station service is fully backward compatible but now supports a POST method to submit a request with arbitrary combinations of network, station, location, channel, start and end time parameters. This new fdsnws-station functionality is essentially the equivalent to the existing fdsnws-dataselect POST capability. Examples of this new capability are available in the online documentation:

    http://service.iris.edu/fdsnws/station/docs/1/help/#postexamples

    All of the service updates are fully backwards compatible with existing data access software with the exception (noted in the previous email) of software that is sensitive to the version number changing. In particular users of IRIS-WS (or MATLAB users using irisFetch.m with IRIS-WS) must be using version 2.0.4 or later.

    regards,
    IRIS DMC


    On Apr 28, 2014, at 3:02 PM, Chad Trabant <chad<at>iris.washington.edu> wrote:

    Hello WS users,

    Tomorrow we will be updating all of our fdnsws web services (dataselect, event and station) to version 1.1 of the specification: http://www.fdsn.org/webservices/

    The vast majority of users will not notice the difference as the changes are very few (the DMC’s services have mostly been 1.1 compliant for a long time). The fdnsws-dataselect and fdsnws-event services will simply have their version number updated. The fdsnws-station service will get a version number update and the service will support a new POST capability as documented in the specification and will be described on the service help pages.

    The version number of the services themselves (as reported at, e.g., http://service.iris.edu/fdsnws/station/1/version) is used by the IRIS-WS Java library, which is used by the DMC’s irisFetch.m MATLAB script, and perhaps other software. All versions of the IRIS-WS library prior to 2.0.4 will cease function properly due to the version change. To ensure uninterrupted data flow please confirm that you are using the latest (2.0.6) version of IRIS-WS, available here:

    http://www.iris.edu/dms/nodes/dmc/software/downloads/IRIS-WS/

    regards,
    IRIS DMC




Page built 12:05:00 | v.44eaca3c