Thread: Removing Instrument Response

Started: 2011-08-28 22:19:03
Last activity: 2011-08-29 00:55:38
Topics: SAC Help
James Smith
2011-08-28 22:19:03
Hello:

I have a set of Canadian seismograms that I need to remove the
instrument response from. I have converted the seed files to sac files
and extracted the RESP files. I am using the following commands in
SAC:

sac> file.sac
sac> rmean
sac> rtrend
sac> taper
sac> trans from evalresp to none freq .01 .015 2 5

When I use the evalresp file I get the following output:

Nominal Calper not set. Setting Nominal Calper to -999.000000 to
match Wfdisc Calper
Sensor Calper not set. Setting Sensor Calper to 1.000000 to match Wfdisc Calper
Response appears to be Un-Normalized.
Waveform appears to be unscaled.
Wfdisc calib value is (769600000.000000).
Waveform multiplied by 1.000000 after deconvolution.

The deconvolved seismogram usually doesn't resemble the original. My
understanding is that removing the instrument response should not in
general change the shape of the seismogram. I've tried applying
various bandpass filters without much luck.

Can anyone tell me if I am missing a step or what could be responsible
for my problem?

Thanks,

James Smith
Colorado State University

  • Januka Attanayake
    2011-08-28 21:29:18
    I think your original seismograms are velocity and since you are using "to none" your out put is displacement. Try doing a dif after the deconvolution and then compare.
     
    _______________
    Serenity isn't freedom from the storm, but peace within the storm

    Januka Attanayake 
    Earthquake Seismology & Economics
    The University of Connecticut
    354, Mansfield Road
    Storrs, CT 06269-2045
    Tel:860 486 3914 (Lab - P405)

    Home page: http://sites.google.com/site/janukaattanayake/
    Research group: http://www.phys.uconn.edu/research/geophysics/index.html








    ________________________________
    From: James Smith <jsmith82<at>gmail.com>
    To: sac-help<at>iris.washington.edu
    Sent: Sunday, August 28, 2011 5:19 PM
    Subject: [SAC-HELP] Removing Instrument Response

    Hello:

    I have a set of Canadian seismograms that I need to remove the
    instrument response from. I have converted the seed files to sac files
    and extracted the RESP files.  I am using the following commands in
    SAC:

    sac> file.sac
    sac> rmean
    sac> rtrend
    sac> taper
    sac> trans from evalresp to none freq .01 .015 2 5

    When I use the evalresp file I get the following output:

    Nominal Calper not set. Setting Nominal Calper to -999.000000 to
    match Wfdisc Calper
    Sensor Calper not set. Setting Sensor Calper to 1.000000 to match Wfdisc Calper
    Response appears to be Un-Normalized.
    Waveform appears to be unscaled.
    Wfdisc calib value is (769600000.000000).
    Waveform multiplied by 1.000000 after deconvolution.

    The deconvolved seismogram usually doesn't resemble the original. My
    understanding is that removing the instrument response should not in
    general change the shape of the seismogram. I've tried applying
    various bandpass filters without much luck.

    Can anyone tell me if I am missing a step or what could be responsible
    for my problem?

    Thanks,

    James Smith
    Colorado State University
    _______________________________________________
    sac-help mailing list
    sac-help<at>iris.washington.edu
    http://www.iris.washington.edu/mailman/listinfo/sac-help
  • Arthur Snoke
    2011-08-29 00:55:38
    Some of the messages may be caused by the fact that the header variable
    SCALE is defined. After reading in file.sac, try

    SAC> scale unset

    and then do the transfer.

    Depending on the kind of seismometer you have and the insrument bandpass,
    the output may not look the same as the input.

    SAC version 101.5 (coming soon) does not use scale, and RDSEED 5.1 does
    not put anything in the SCALE sac header.

    On Sun, 28 Aug 2011, James Smith wrote:

    Hello:

    I have a set of Canadian seismograms that I need to remove the
    instrument response from. I have converted the seed files to sac files
    and extracted the RESP files. I am using the following commands in
    SAC:

    sac> file.sac
    sac> rmean
    sac> rtrend
    sac> taper
    sac> trans from evalresp to none freq .01 .015 2 5

    When I use the evalresp file I get the following output:

    Nominal Calper not set. Setting Nominal Calper to -999.000000 to
    match Wfdisc Calper
    Sensor Calper not set. Setting Sensor Calper to 1.000000 to match Wfdisc Calper
    Response appears to be Un-Normalized.
    Waveform appears to be unscaled.
    Wfdisc calib value is (769600000.000000).
    Waveform multiplied by 1.000000 after deconvolution.

    The deconvolved seismogram usually doesn't resemble the original. My
    understanding is that removing the instrument response should not in
    general change the shape of the seismogram. I've tried applying
    various bandpass filters without much luck.

    Can anyone tell me if I am missing a step or what could be responsible
    for my problem?

    Thanks,

    James Smith
    Colorado State University

00:58:04 v.22510d55