SAC Help

A forum for SAC users to exchange ideas and ask questions about SAC usage, installation, portability, etc.

Email address
Moderated by
IRIS Webmaster
Related tags
SAC Software SAC

Active Message Threads for May 2010

Hi All, I have a compilation problem (look at the bottom). Is that because I have got the binary sac version for OSX (Version 101.3b) that is compiled for a 64 bit architecture? I have to use -m32 because otherwise I get " missing required architecture x86_64 in file". Should I get the source code to be compiled for 32 bit so that I have the right library? Or maybe there is another solution? Thank you for the help. Paola bash-3.2$ gfortran -m32 -C Masterprogram.o /usr/local/sac/lib/libsac… [more]
No replies
Isaac Mulamba
2010-05-29 13:23:34 - 2010-05-29 21:42:18
(no body)
Danilo Domingos
2010-05-29 05:13:37
Hello everyone! Ok, where to begin? I have to calculate the PGA (peak ground acceleration) of some events, and to do that I have 2 options: 1) Use the SAC function TRANSFER to convert the original displacement data to acceleration. 2) Manually convert the data to velocity (using seismometer and digitizer parameters), and then differenciate to acc. Why is this 2nd option there? Because I've tried to understant how to build the POLEZERO file too many times. The poles and zeros aren't a pr… [more]
2010-05-26 16:13:10 - 2010-05-27 21:23:16
Thanks Milton for quick reply. Since in our later data processing the phase plays an important role, I am wondering if the interp or decimate will keep the phase in low freqency, for example lower than 0.4Hz. It seems that the decimate cmd performs an anti-alias filter, but document on interp does not show that. By comparing the origin data and interped and decimated ones in a short time gap, say two seconds, we may find all the decimated data points can be found in the origin data but interp… [more]
Hi All When I tried to downsample a sac data using decimate command,I encountered a curious problem on the delta change. Suppose we have one data with samplng rate 100hz, and we want to downsample to 1hz. the cmd I used is decimate 5, now delta=0.05; decimate 5 now=delta=0.25 decimate 2 now delta=0.5 decimate 2 now delta=0.999999 in the final step the delta is 0.999999 instead of 1.0. Since our later processing need to check the consistent of and we have some LHZ sac with de… [more]
No replies
2010-05-24 20:54:46 - 2010-05-25 20:28:38
Hi all!! I have problems to picks phases in sac, I use command PLOTPK, but the phases does not save in header, could someone help me? Best regards, Astrid López
Carolina Buffoni
2010-05-25 17:08:36 - 2010-05-25 17:10:58
Dear All, I'm new with the SAC list help and my problem is that I can't plot traces. The home machine is running Fedora. I can read the trace and header but when I try to plot it, this message error appear: X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 45 (X_OpenFont) Serial number of failed request: 7 Current serial number in output stream: 11 I would appreciate if you help me with this problem. Thanks, Carolina … [more]
奕敦 陳
2010-05-20 23:30:19
Greeting, I found that my new-installed SAC program alway occupys the memory. Basically, the SAC program will release the memory space from the forward file when I read a new one. But in my situation, the memory space is still occupied by the forward read-in file. Even if I read a new file or input 'deletechannel all'. This way, when I runs the macro scrip, the memory will run out soon. The only way to release the memory space is to turn off the SAC and run a new one. My SAC versi… [more]
No replies
Nitin Sharma
2010-05-14 04:06:02
Hello Sir/Mam,  I am Learning SAC as a beginner. I am facing Some problem regarding Convolution operation. If I use the command Convolve provided in SAC Then I get Satisfactory results. But If Perform the similar operation in frequency Domain my results do not match with the results obtained using convolve command. What I have done is I took 2 functions (step and Boxcar), compute fft and obtained their .am and .ph files separately. Then I multiply the both .am files and add up the both .p… [more]
No replies
Frederik Tilmann
2010-05-12 01:44:20
Hi I can't get fg random to work with pre-compiled 64 bit version: SEISMIC ANALYSIS CODE [08/24/2009 (Version 101.3b)] Copyright 1995 Regents of the University of California SAC> fg random SAC> lh depmin depmax FILE: RANDOM01 - 1 -------------- depmin = -nan depmax = -nan SAC> Has anyone else encountered this? Regards Frederik
gaurav dutta
2010-05-11 00:26:55
Dear Sir, I have got the SAC software as an email attachment in the form sac-101.3b-linux_x86_32.tar.gz. I have expanded the file using the following command in the command line tar -xzf sac-101.3b-linux_x86_32.tar.gz A sac folder has been created on my desktop. I now need to get started with the software but i have not been able to figure out how to do so. Please help me on my further steps. Gaurav Dutta
No replies
Katie Boyle
2010-05-06 16:00:35 - 2010-05-06 20:56:10
Hi, Are there 64-bit compatible versions of rsac1.f wsac1.f, etc? Thanks! Katie
Onur Tan
2010-04-26 22:05:20 - 2010-05-06 19:11:28
Hello, How can I convert SAC file to SEG2 format ? best regards Onur for Brian: The manual of the “write” command on the web and its help file in SAC are different. There is no information about SEGY format in the web page. However their revision date are the same. Dr. Onur TAN ---------------------------------------------- 40.7866N 29.4500E --------- TÜBİTAK Marmara Araştırma Merkezi, Yer ve Deniz Bilimleri Enstitüsü TUBITAK Marmara Research Center, Earth and Marine Sciences Inst… [more]
2010-05-03 03:37:17
Dear sir: I am trying to use the "convolve" command in sac2000,but there is something wrong with it. I type these commands below: >r R1.sac R2.sac >convolve it produce the following error >remove this function: src/co/zmemad() I don't know why.Could you please help me solve this problem. Yours , Chen Haopeng
No replies
2010-05-02 17:16:58
Dear sir: I am trying to use the "convolve" command in sac2000,but there is something wrong with it. I type these commands below: >r R1.sac R2.sac >convolve it produce the following error >remove this function: src/co/zmemad() I don't know why.Could you please help me solve this problem. Yours , Chen Haopeng
No replies
20:39:39 v.ad6b513c