SAC Help

A forum for SAC users to exchange ideas and ask questions about SAC usage, installation, portability, etc.

Email address
Moderated by
IRIS Webmaster
Related tags
SAC Software SAC

Active Message Threads for August 2013

Luyuan Ding via LinkedIn
2013-08-29 07:41:16
LinkedIn ------------ Luyuan Ding requested to add you as a connection on LinkedIn: ------------------------------------------ Sac Help, I'd like to add you to my professional network on LinkedIn. - Luyuan Accept invitation from Luyuan Ding… [more]
No replies
raja babu
2013-08-24 17:57:42
Respected Sir/Madam After untar the file the sac-101.5c-mac_32i.tar.gzfile i have set path but still i am getting error as "/home/raja/PROG/SACNEW/sac/bin/sac: Exec format error. Binary file not executable." because SAC command is not excutable...that is just a binary file in bin directry. So help me your faithful raja babu research scholars National Geophysical Research Institute Hyderabad India
Milton Plasencia
2013-08-24 15:32:49
So, then you must use a sac version for linux and not for MAC-OSX do: > uname -a in you system for detrmining if you PC is 64 bits for example: [milton@pcasain7 ~]$ uname -a Linux 2.6.32-358.14.1.el6.x86_64 #1 SMP Tue Jul 16 23:51:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux Here you can see X86_64, so my system is 64 bits and you must use the sac version for 64 bits the last version is: sac-101-6.linux_x86_64.tar.gz Cheers, Milton P. Plasencia Linares mpplasencia@gma… [more]
No replies
2013-08-22 17:21:54
Hi, I have a problem with passing arguments and using the blackboard variables in the version 101.6. The code worked perfectly in the previous versions. Is there a solution to this in the v. 101.6? Has the syntax changed? Please see an example below. The v.101.6 gives me an error on "ls" while the previous versions listed the files. setbb wd ../20080903_1125 setbb path1 %wd%/data cp %path1%/*.SAC . cp: cannot stat `%path1%/*.SAC': No such file or directory ls %path1%/ ls: cannot access %p… [more]
No replies
Tannistha Maiti
2013-08-16 23:59:35 - 2013-08-21 05:03:26
Hello, I would like to modify the EVLA and EVLO values in the header using bash script. The lat and long values are stored in coord.txt file. I used the following script but not sure why it is not reading from the file. The coord file contains two values column 1 lat and column 2 long. #bin/bash! saclst evlo evla f|awk '{a+=$1} {b+=$2} {printf "r NET.STA1216..BXE.sac\nch %f %f \nwh\nq\n",a,b} END{print "quit"}' | sac coord.txt However this command works. printf "r NET.STA1216..BXE.sac\nch e… [more]
2013-08-19 22:39:00 - 2013-08-20 16:20:43
Hello, I'm having a couple of problems with sac: 1) PROBLEMS WITH PLOTSP: after reading a file and using xlim to have only part of the signal, then fft, I can't plot the spectrum, it simply displays a white window. So, basically, it works if I do: r file fft psp But it doesn't work if I do: r file xlim 100 200 fft psp I also have a problem using Sac Graphic Files and then plotsp. I can create a correct figure when reading only one file, but not if I read many files. r file1 file2 file3 f… [more]
2013-08-19 00:27:28 - 2013-08-19 17:05:24
Hiii, I am a beginner to SAC and I am trying to pick and display phases on seismograms using PPK. I will really appreciate some help on this. SAC>read filename SAC>p1 SAC>ppk # using curser, I click on a point and press p to show P-wave pick, then i press q to get #out of ppk SAC>p1 but now the plot shows IPUO instead of just P and it shows ISUO instead of S. I tried assigning t0, t1 to phase picks, and then trying to change the name using PICKPHASE, but for some reason it doesn't work (or m… [more]
Sunil Kapur
2013-08-17 16:36:31
Hello I am a doctoral student at University of Houston. I am working on automatic arrival picking. I have data in .dat format. I want to perform polarization on it so I came across your matlab code. But it uses SAC format. Can you please guide me on how can I use dat format in this code. Also, can you provide me with some sample SAC file . Thankx. Thanking you Alot Sunil Kapur
No replies
Martha Savage
2013-08-11 05:11:35
Hi, I have a similar problem with passing arguments in version 101.6 and not with any of the earlier versions. I have had to revert to the old version to get my codes to work. The problem seems to be that a variable that was defined by the "keys" command isn't passed properly into a "do" loop. (the variable in question is called "file". I tried calling it "filein" in case there was a pre-set definition of "file" but that didn't change anything.) I also tried leaving out the quotes in the c… [more]
No replies
Zachary Fisher
2013-08-03 02:40:42 - 2013-08-05 07:57:35
Hi, I'm trying to support an end user grad student who would like to be able to compile with g77 because of older code. When she tries to compile, she receives the following error: /Users/sanja/RWI > g77 rsac1f.f -o rsac1 /usr/local/sac/lib/sacio.a ld: warning: -macosx_version_min not specified, assuming 10.7 ld: warning: ignoring file /usr/local/sac/lib/sacio.a, file was built for archive which is not the architecture being linked (i386): /usr/local/sac/lib/sacio.a Undefined symbols for ar… [more]
2013-08-01 23:11:04 - 2013-08-02 21:13:56
(no body)
jiajun chong
2013-08-01 18:25:45 - 2013-08-02 16:06:34
Hi there, I have a problem when running a SAC macro using sac101.6, but it works well with older version. I don't know what's going on. Is there anyone can help me? the error information: Syntax error: setbb radial '(CHANGE 'HZ' 'HR' %vert)' and here is the SAC macro as following: sc mkdir Trash sc mkdir GoodOnes qdp off do file wild *HZ.sac setbb vert $file setbb radial '(CHANGE 'HZ' 'HR' %vert)' setbb tang '(CHANGE 'HZ' 'HT' %vert)' r %vert %radial %tang bp n 4 c 0.005 0.05 … [more]
Steve Gao
2013-08-02 00:04:16
I'm also having an issue with 101.6. A SAC macro program, which worked under 101.2, crashed under 101.6 (see below). I do not have any problems with reading and displaying SAC files using 101.6. The platform is x86-64 Ubuntun Linux. Any hints? Thanks. Stephen S. Gao ---------------------------------------------------------- SEISMIC ANALYSIS CODE [06/12/2013 (Version 101.6)] Copyright 1995 Regents of the University of California SIUCxx_NM.z SIUCxx_NM.n SIUCxx_NM.… [more]
No replies
Sheila Peacock
2013-08-01 17:26:28
Dear all, My colleague showed me a problem with our installation of SAC 101.6: it does not accept command-line arguments for substitution for "$1", etc. The most trivial example is: macro jj.mac contains r $1 $2 p It is invoked by: sac1016c jj.mac 20130205_020000.EKB10.BHZ.sac 20130205_020000.EKB1.BHZ.sac and gives the error message ERROR 1014: Undefined variable in command: 1 This works OK with SAC 101.5c It looks as if SAC 101.6, or the OS, has stripped off the leading $ signs fro… [more]
No replies
06:29:33 v.22510d55