SAC Help

A forum for SAC users to exchange ideas and ask questions about SAC usage, installation, portability, etc.

Email address
Moderated by
IRIS Webmaster
Related tags
SAC Software SAC

Active Message Threads for June 2010

Megan Torpey
2010-06-21 22:00:55 - 2010-06-22 18:45:02
Hi, I'm having a SAC problem. I'm running a program to digitize paper seismograms. My digitization program saves the files I create as .SAC files. I got one digitized and saved it as .SAC but when I tried to read the file into SAC I got the following error: ERROR 1318: Header in disk file is out of date: myfile Header version number is incorrect. Header seems byte-swapped—byte-swap file and retry. I looked up sac help online and I got :… [more]
  • Re: HELP! - Arthur Snoke - 2010-06-21 23:44:35
    • Re: HELP! - Brian Savage - 2010-06-22 18:45:02
  • Re: HELP! - Marcelo Bianchi - 2010-06-22 04:19:46
Mohit Agrawal
2010-06-22 16:15:16
Hello I am downloading the data for the GSN stations with the help of SOD but after looking at the seismogram , I noticed that I am getting variable length of seismogram. Can you please tell me "how can I solve this problem". Thanks Mohit
No replies
Arthur Snoke
2010-06-10 04:14:34
Version 101.4 of SAC is now available for download from URL <>. For a summary of the changes between this version and 101.3b (released August 2009), one can view the HISTORY file at <>. That file, as well as the more detailed CHANGES file, can also be accessed from the IRIS software/sac page. As before, there are binary distributions for Sun Solaris, Linux (32 bit and 64 bit) and Mac OS X. There are now two b… [more]
No replies
Shahar Shani Kadmiel
2010-06-09 22:02:49
I am trying to compile a short c code using some subroutines from sacio.a I get this error: sacio.a: could not read symbols: Archive has no index; run ranlib to add one collect2: ld returned 1 exit status When I run ranlib, I get this: ranlib: sacio.a: Malformed archive I have a feeling this has to do with the fact I am using the sacio.a archive which is distributed with MacSAC and is not compatible with the linux machine I am compiling on. What to do?
Shahar Shani Kadmiel
2010-06-09 00:12:38 - 2010-06-09 17:36:11
I have written a short code in c utilizing the "wsac1" subroutine. When compiling, I get this: Undefined symbols: "_wsac1", referenced from: _main in cc7iJC76.o ld: symbol(s) not found collect2: ld returned 1 exit status This is the only problem and when I comment out the line containing wsac1 the program compiles with no errors. The part after _main, where it says "cc7iJC76.o", changes with every try. This is my compile line: cc codeName.c -o codeName -lm -m32 sacio.a where sacio… [more]
Hi Brian, I am not sure you got my reply including the information you asked, so I forward it in this email. Also, I tried to substitute the sac bin version with the sac source version, but after the installation I still get the same error: bash-3.2$ make Masterprogram gfortran -m32 Masterprogram.o /usr/local/sac/lib/libsac.a /usr/local/sac/lib/sacio.a -o Masterprogram Undefined symbols: "_cmmem", referenced from: _cmmem$non_lazy_ptr in sacio.a(writevfile.o) _cmmem$non_lazy_pt… [more]
No replies
gaurav dutta
2010-06-05 23:18:31
Dear Sir, How to convert data which is in sac format into ascii format ?
Katie Boyle
2010-06-04 15:18:38 - 2010-06-04 20:55:29
Hi All, Every time I run SAC, it barfs this out (all I did for this example was type 'sac' and then immediately typed 'quit'): me@me-desktop:~$ sac SEISMIC ANALYSIS CODE [09/04/2008 (Version 101.2)] Copyright 1995 Regents of the University of California SAC> quit *** glibc detected *** sac: free(): invalid next size (fast): 0x09ba1178 *** ======= Backtrace: ========= /lib/tls/i686/cmov/[0xb7d06454] /lib/tls/i686/cmov/[0xb7d084b6] sac[0x81e5fc6] sac[0x81d82eb] … [more]
Andreas Wuestefeld
2010-06-01 22:27:37 - 2010-06-03 12:59:23
Dear Isaac, Aldo I have lately had to install CYGWIN & SAC on several WIN7 computers, and I cannot reproduce the error. I assume you have a Win7 system with admin previliges, and use the latest release of CYGWIN (ver1.7.x)? Win7 has a rather strict permission policy, which sometimes results in files opened/upacked under windows are not accesible in cygwin. a "chmod" ususally helps I suggest that you unpack and untar the sac-101.3b-cygwin.tar.gz under cygwin and not Windows check manual… [more]
Dear All: When I try to picking phase arrival in plotpk window, I type ohpf to create a hypo file before phase picking. I can get correct P-phase arrival time after I typing "P" to decide the P-phase, however, I cannot get S-phase arrival time when I type "S" to decide the S-phase, the arrival time of S-phase reveals 0.0 both in the PPK window and in the hypo file. how can I resolve this problem? Thanks all for your help.
No replies
Jesse F Lawrence
2010-06-01 19:57:51
Hi, I am writing a set of subroutines to read in sac header information into the format I need for my program. On a unix machine I have no problems, but on linux I get the following error message: ERROR 1336: Undefined header field value. kuser0 I have filled this variable on my sac files. I can proceed despite the error, but it is not satisfying to have a bunch of error messages come up. Any suggestions? Any fixes? Any way to suppress the error message? Cheers, -Jesse -----… [more]
No replies
15:41:25 v.ad6b513c